lunes, 10 de octubre de 2011

sk1 no abre en LinuxMint [¡solucionado!]

Para utilizar en un trabajo, que estaba haciendo en Linux Mint, me enviaron un archivo con extensión .AI (de Adobe Illustrator). Lo primero que intenté fue abrirlo directamente desde Inkscape, pero no hubo suerte.
Luego, quise probar con el sk1, que había instalado, entre otros muchos paquetes, inmediatamente después de haber instalado LinuxMint en la PC del trabajo. Pero, desde el menú, el sk1 no levantaba. Probé desde la Terminal y tampoco funcionaba.

Googleando encontré que existían paquetes específicos de sk1 para Linux Mint, porque no siempre los paquetes del sk1 para Ubuntu funcionaban en Linux Mint. Así que, desinstalé el sk1 del sistema y, aunque tengo instalado Linux Mint 11, instalé sk1 con los paquetes para Linux Mint 9 en la página de descargas de sk1.



Contento al creer que había encontrado la solución, intenté arrancar el programa desde el menú principal, pero tampoco levantó. Probé de nuevo desde la Terminal, y nuevamente falló, pero esta vez, tomé nota del mensaje de error:

Traceback (most recent call last):
File "/usr/bin/sk1", line 22, in module
from sk1 import sk1_run
ImportError: No module name sk1


Con esa información, sí pude encontrar la solución. En una respuesta de john0 a una entrada en el foro de soporte de sk1 se da con el problema: al parecer los paquetes de instalación incluyen unos vínculos que apuntan a lugares equivocados. Así que hay que generar unos enlaces simbólicos que apunten al lugar correcto. Para ello, como suscribe john0, hay que escribir en una terminal las siguientes tres líneas:

sudo ln -s /usr/lib/python2.6/dist-packages/sk1 /usr/lib/python2.7/dist-packages/
sudo ln -s /usr/lib/python2.6/dist-packages/sk1libs /usr/lib/python2.7/dist-packages/
sudo ln -s /usr/lib/python2.6/dist-packages/sk1sdk /usr/lib/python2.7/dist-packages/


Con esto sí pude abrir el sk1, y desde él pude abrir el archivo .AI (que no importó correctamente los rellenos -principalmente los gradientes-, pero ese es otro problema).
[ ACTUALIZACIÓN del 30 de Noviembre de 2011 ] Hoy tenía que usar el sk1 en Kubuntu y resulta que se me presentó el mismo problema, que, por suerte, funcionó con la misma solución.

11 comentarios:

  1. Gracias instale Linux Mint11 y despues de luchar por instalar Corel probe inkscape y no me guste, instela sk1 para probarlo y no abria tu solucion funciono.
    Gracias.
    Carlos de Argentina

    ResponderEliminar
  2. Gracias por el aporte me de mucha utilidad

    ResponderEliminar
  3. Muy buen Aporte, tenía el mismo problema en Kubuntu y se soluicionó.

    Gracias.

    ResponderEliminar
  4. Te agrego información también funciona en debían tanto con sk1 como converter
    Gracias por el aporte.

    ResponderEliminar
  5. hola sabes que me instalado el programa pero resulta que me da es el siguiente error:

    Traceback (most recent call last):
    File "/usr/bin/sk1", line 23, in
    sk1_run()
    File "/usr/lib/python2.7/dist-packages/sk1/__init__.py", line 26, in sk1_run
    import app
    File "/usr/lib/python2.7/dist-packages/sk1/app/__init__.py", line 58, in
    import main
    File "/usr/lib/python2.7/dist-packages/sk1/app/main.py", line 29, in
    import app
    File "/usr/lib/python2.7/dist-packages/sk1/app/__init__.py", line 58, in
    import main
    File "/usr/lib/python2.7/dist-packages/sk1/app/main.py", line 30, in
    from sk1libs.utils import Empty
    ImportError: No module named sk1libs.utils

    eh buscado y nada sabes que puede ser? agradeceria mucho tu ayuda...

    ResponderEliminar
  6. Hola Anthony.
    No sé que es lo que pasa.
    Hay que tener en cuenta que el sk1 está siendo discontinuado en favor de un programa nuevo llamado PrintDesing (como dicen en http://sk1project.org/news.php?readmore=68), pero, al parecer, el proyecto viene algo lento.
    Igualmente, ¿en algún momento pudiste abrir el programa? ¿o el error aparece desde la instalación y nunca arrancó?
    Si es el segundo caso, habría que asegurarse que usaste los instaladores correspondientes a la arquitectura de tu computadora.
    Pero, supongo que eso ya lo hiciste...

    ResponderEliminar
  7. Dios mio me has ayudado con esto post, te la has rifado, gracias!!

    ResponderEliminar
  8. Gracias!!!
    Mesma solução encontrada usando pacote para o Ubuntu no Linux Mint 14, mais as linhas que você ensinou.

    ResponderEliminar
  9. soy nuevo en linux ya instale los tres paquetes que publico javier sam pero como ejecuto el programa

    ResponderEliminar
    Respuestas
    1. Podrías probar desde la Terminal (que normalmente está en "Menú/Accesorios") y en ella escribir "sk1" (sin las comillas) y dar "Enter".

      Eliminar
  10. hola, no sé qué he hecho mal. Instalé el sk1, lo ejecuto desde Terminal, en Mint, y no hace nada de nada.... Agradezco orientación

    ResponderEliminar

Lo que escriba a continuación será revisado antes de publicarse.
Gracias por tus comentarios.